package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b([0-9]+\.){2}[0-9]+\S*`)
var str = `Found git tag v6.0.0 associated with version 6.0.0 on branch main
Found git tag v6.0.0 associated with version 6.0.0-main.2 on branch main
The next release version is 7.0.0
The next release version is 7.0.0-main.12
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}