use strict;
my $str = 'Found git tag v6.0.0 associated with version 6.0.0 on branch main
Found git tag v6.0.0 associated with version 6.0.0-main.2 on branch main
The next release version is 7.0.0
The next release version is 7.0.0-main.12
';
my $regex = qr/\b([0-9]+\.){2}[0-9]+\S*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}