using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{-?\h*([\w']{3,}(?:\h+[\w']+)*)\h*}";
string input = @"{test}
{Project D'arce}
{ test }
{ test test }
{ }";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}