package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{-?\h*([\w']{3,}(?:\h+[\w']+)*)\h*}`)
var str = `{test}
{Project D'arce}
{ test }
{ test test }
{ }`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}