re = /\{-?\h*([\w']{3,}(?:\h+[\w']+)*)\h*}/m
str = '{test}
{Project D\'arce}
{ test }
{ test test }
{ }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end