$re = '/\{-?\h*([\w\']{3,}(?:\h+[\w\']+)*)\h*}/m';
$str = '{test}
{Project D\'arce}
{ test }
{ test test }
{ }';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);