using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/s3\.eu-west-3\.amazonaws\.com\/[^>]+";
string input = @"https://s3.eu-west-3.amazonaws.com/sd56sqs/sd56sqs.html#qs=r-aghbhafcdbgkfgfaekhkggeakjefifcadkeheabababadgaffaceadhgadgheakcdggacb";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}