re = /https?:\/\/s3\.eu-west-3\.amazonaws\.com\/[^>]+/m
str = 'https://s3.eu-west-3.amazonaws.com/sd56sqs/sd56sqs.html#qs=r-aghbhafcdbgkfgfaekhkggeakjefifcadkeheabababadgaffaceadhgadgheakcdggacb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end