const regex = /https?:\/\/s3\.eu-west-3\.amazonaws\.com\/[^>]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/s3\\.eu-west-3\\.amazonaws\\.com\\\/[^>]+', 'gm')
const str = `https://s3.eu-west-3.amazonaws.com/sd56sqs/sd56sqs.html#qs=r-aghbhafcdbgkfgfaekhkggeakjefifcadkeheabababadgaffaceadhgadgheakcdggacb`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}