package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?:\/\/s3\.eu-west-3\.amazonaws\.com\/[^>]+`)
var str = `https://s3.eu-west-3.amazonaws.com/sd56sqs/sd56sqs.html#qs=r-aghbhafcdbgkfgfaekhkggeakjefifcadkeheabababadgaffaceadhgadgheakcdggacb`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}