using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)found housing|housing found";
string input = @"1 I found housing, but I don't have a job yet
2 I found clothes, but not housing
3 I housing found, but I don't have a job yet";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}