$re = '/(?i)found housing|housing found/m';
$str = '1 I found housing, but I don\'t have a job yet
2 I found clothes, but not housing
3 I housing found, but I don\'t have a job yet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);