// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)found housing|housing found").unwrap();
let string = "1 I found housing, but I don't have a job yet
2 I found clothes, but not housing
3 I housing found, but I don't have a job yet";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}