use strict;
my $str = '1 I found housing, but I don\'t have a job yet
2 I found clothes, but not housing
3 I housing found, but I don\'t have a job yet';
my $regex = qr/(?i)found housing|housing found/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}