const regex = /^(.*) (\w\w\w) (\2)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*) (\\w\\w\\w) (\\2)$', 'gm')
const str = `A Nightmare On Elm Street 720p Bluray X264-Pahe In mkv mkv
Austin Powers International Man Of Mystery 480p Bluray 300mb-Pahe In mkv mkv
Death_warrant_1990_720p_bluray_x264_750mb-Pahe In mkv mkv
Die Frau Des Polizisten 720p Bluray X264-Pahe In mkv mkv`;
const subst = `\1.\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);