use strict;
my $str = 'A Nightmare On Elm Street 720p Bluray X264-Pahe In mkv mkv
Austin Powers International Man Of Mystery 480p Bluray 300mb-Pahe In mkv mkv
Death_warrant_1990_720p_bluray_x264_750mb-Pahe In mkv mkv
Die Frau Des Polizisten 720p Bluray X264-Pahe In mkv mkv';
my $regex = qr/^(.*) (\w\w\w) (\2)$/mp;
my $subst = '\\1.\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";