using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^BRN.*?(?:paid|to)\s(?![A-Za-z\s]*\bself\b)([A-Za-z\s]+)";
string input = @"BRN CLG-CI IQ PAID IONANDA PAUL
//////
BRN-TO CASH SELF";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}