re = /^BRN.*?(?:paid|to)\s(?![A-Za-z\s]*\bself\b)([A-Za-z\s]+)/im
str = 'BRN CLG-CI IQ PAID IONANDA PAUL
//////
BRN-TO CASH SELF'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end