const regex = new RegExp('^BRN.*?(?:paid|to)\\s(?![A-Za-z\\s]*\\bself\\b)([A-Za-z\\s]+)', 'gim')
const str = `BRN CLG-CI IQ PAID IONANDA PAUL
//////
BRN-TO CASH SELF`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}