import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^BRN.*?(?:paid|to)\\s(?![A-Za-z\\s]*\\bself\\b)([A-Za-z\\s]+)";
final String string = "BRN CLG-CI IQ PAID IONANDA PAUL\n"
+ "//////\n"
+ "BRN-TO CASH SELF";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}