#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=<[Ss][Cc][Rr][Ii][Pp][Tt]>)([\s\S]*?)(?=<\/[Ss][Cc][Rr][Ii][Pp][Tt]>)"
Local $sString = "<script>test</script>" & @CRLF & _
"" & @CRLF & _
"<SCRIPT>" & @CRLF & _
"Example" & @CRLF & _
"</SCRIPT>" & @CRLF & _
"" & @CRLF & _
" <script>" & @CRLF & _
" (function() {" & @CRLF & _
" var widget_id = 825946;" & @CRLF & _
" _shcp = [{" & @CRLF & _
" widget_id: widget_id" & @CRLF & _
" }];" & @CRLF & _
" var lang = (navigator.language || navigator.systemLanguage || navigator.userLanguage || "en")" & @CRLF & _
" .substr(0, 2).toLowerCase();" & @CRLF & _
" var url = "widget.siteheart.com/widget/sh/" + widget_id + "/" + lang + "/widget.js";" & @CRLF & _
" var hcc = document.createElement("script");" & @CRLF & _
" hcc.type = "text/javascript";" & @CRLF & _
" hcc.async = true;" & @CRLF & _
" hcc.src = ("https:" == document.location.protocol ? "https" : "http") + "://" + url;" & @CRLF & _
" var s = document.getElementsByTagName("script")[0];" & @CRLF & _
" s.parentNode.insertBefore(hcc, s.nextSibling);" & @CRLF & _
" })();" & @CRLF & _
" </script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")