using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<[Ss][Cc][Rr][Ii][Pp][Tt]>)([\s\S]*?)(?=<\/[Ss][Cc][Rr][Ii][Pp][Tt]>)";
string input = @"<script>test</script>
<SCRIPT>
Example
</SCRIPT>
<script>
(function() {
var widget_id = 825946;
_shcp = [{
widget_id: widget_id
}];
var lang = (navigator.language || navigator.systemLanguage || navigator.userLanguage || ""en"")
.substr(0, 2).toLowerCase();
var url = ""widget.siteheart.com/widget/sh/"" + widget_id + ""/"" + lang + ""/widget.js"";
var hcc = document.createElement(""script"");
hcc.type = ""text/javascript"";
hcc.async = true;
hcc.src = (""https:"" == document.location.protocol ? ""https"" : ""http"") + ""://"" + url;
var s = document.getElementsByTagName(""script"")[0];
s.parentNode.insertBefore(hcc, s.nextSibling);
})();
</script>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}