use strict;
my $str = '<script>test</script>
<SCRIPT>
Example
</SCRIPT>
<script>
(function() {
var widget_id = 825946;
_shcp = [{
widget_id: widget_id
}];
var lang = (navigator.language || navigator.systemLanguage || navigator.userLanguage || "en")
.substr(0, 2).toLowerCase();
var url = "widget.siteheart.com/widget/sh/" + widget_id + "/" + lang + "/widget.js";
var hcc = document.createElement("script");
hcc.type = "text/javascript";
hcc.async = true;
hcc.src = ("https:" == document.location.protocol ? "https" : "http") + "://" + url;
var s = document.getElementsByTagName("script")[0];
s.parentNode.insertBefore(hcc, s.nextSibling);
})();
</script>';
my $regex = qr/(?<=<[Ss][Cc][Rr][Ii][Pp][Tt]>)([\s\S]*?)(?=<\/[Ss][Cc][Rr][Ii][Pp][Tt]>)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}