const regex = /(?<=<[Ss][Cc][Rr][Ii][Pp][Tt]>)([\s\S]*?)(?=<\/[Ss][Cc][Rr][Ii][Pp][Tt]>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=<[Ss][Cc][Rr][Ii][Pp][Tt]>)([\\s\\S]*?)(?=<\\\/[Ss][Cc][Rr][Ii][Pp][Tt]>)', 'g')
const str = `<script>test</script>
<SCRIPT>
Example
</SCRIPT>
<script>
(function() {
var widget_id = 825946;
_shcp = [{
widget_id: widget_id
}];
var lang = (navigator.language || navigator.systemLanguage || navigator.userLanguage || "en")
.substr(0, 2).toLowerCase();
var url = "widget.siteheart.com/widget/sh/" + widget_id + "/" + lang + "/widget.js";
var hcc = document.createElement("script");
hcc.type = "text/javascript";
hcc.async = true;
hcc.src = ("https:" == document.location.protocol ? "https" : "http") + "://" + url;
var s = document.getElementsByTagName("script")[0];
s.parentNode.insertBefore(hcc, s.nextSibling);
})();
</script>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}