#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((25[0-5]|(2[0-4]|1\d|[1-9])?\d)(\.(?!$)|$)){4}$"
Local $sString = "192.168.0.12" & @CRLF & _
"255.255.255.0" & @CRLF & _
"256.178.222.345" & @CRLF & _
"218.255.1.0" & @CRLF & _
" 1.1.1.1 e ip 192.168.10.3" & @CRLF & _
"0.0.0.0" & @CRLF & _
"192.0.9.25" & @CRLF & _
"33.1.1.1" & @CRLF & _
"123.1.5.4" & @CRLF & _
"1.10.100.3" & @CRLF & _
"3." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://192.168.255.111/teste" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"30.168.1.255.1" & @CRLF & _
"127.1" & @CRLF & _
"192.168.1.256" & @CRLF & _
"-1.2.3.4 " & @CRLF & _
"1.1.1.1." & @CRLF & _
"3...3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")