use strict;
my $str = '192.168.0.12
255.255.255.0
256.178.222.345
218.255.1.0
1.1.1.1 e ip 192.168.10.3
0.0.0.0
192.0.9.25
33.1.1.1
123.1.5.4
1.10.100.3
3.
http://192.168.255.111/teste
30.168.1.255.1
127.1
192.168.1.256
-1.2.3.4
1.1.1.1.
3...3';
my $regex = qr/^((25[0-5]|(2[0-4]|1\d|[1-9])?\d)(\.(?!$)|$)){4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}