const regex = new RegExp('^((25[0-5]|(2[0-4]|1\\d|[1-9])?\\d)(\\.(?!$)|$)){4}$', 'gm')
const str = `192.168.0.12
255.255.255.0
256.178.222.345
218.255.1.0
1.1.1.1 e ip 192.168.10.3
0.0.0.0
192.0.9.25
33.1.1.1
123.1.5.4
1.10.100.3
3.
http://192.168.255.111/teste
30.168.1.255.1
127.1
192.168.1.256
-1.2.3.4
1.1.1.1.
3...3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}