#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z](?=.{1,29}$)[A-Za-z]*(?:\h+[A-Z][A-Za-z]*)*$"
Local $sString = "Tes" & @CRLF & _
"T" & @CRLF & _
"test" & @CRLF & _
"Test Test" & @CRLF & _
"Test testTest testTest testfsr" & @CRLF & _
"Test testTest testTest testfsrf" & @CRLF & _
"Test testTest testTest testfs " & @CRLF & _
"" & @CRLF & _
"Testing Testing Testing Testin" & @CRLF & _
"Testing Testing Testing Testing" & @CRLF & _
"Testing Testing Testing Test " & @CRLF & _
"Testing Testing Testing Test g" & @CRLF & _
"Testing Testing Testing Test T"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")