$re = '/^[A-Z](?=.{1,29}$)[A-Za-z]*(?:\h+[A-Z][A-Za-z]*)*$/m';
$str = 'Tes
T
test
Test Test
Test testTest testTest testfsr
Test testTest testTest testfsrf
Test testTest testTest testfs
Testing Testing Testing Testin
Testing Testing Testing Testing
Testing Testing Testing Test
Testing Testing Testing Test g
Testing Testing Testing Test T';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);