const regex = /^[A-Z](?=.{1,29}$)[A-Za-z]*(?:\h+[A-Z][A-Za-z]*)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z](?=.{1,29}$)[A-Za-z]*(?:\\h+[A-Z][A-Za-z]*)*$', 'gm')
const str = `Tes
T
test
Test Test
Test testTest testTest testfsr
Test testTest testTest testfsrf
Test testTest testTest testfs
Testing Testing Testing Testin
Testing Testing Testing Testing
Testing Testing Testing Test
Testing Testing Testing Test g
Testing Testing Testing Test T`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}