import re
regex = re.compile(r"^[A-Z](?=.{1,29}$)[A-Za-z]*(?:\h+[A-Z][A-Za-z]*)*$", flags=re.MULTILINE)
test_str = ("Tes\n"
"T\n"
"test\n"
"Test Test\n"
"Test testTest testTest testfsr\n"
"Test testTest testTest testfsrf\n"
"Test testTest testTest testfs \n\n"
"Testing Testing Testing Testin\n"
"Testing Testing Testing Testing\n"
"Testing Testing Testing Test \n"
"Testing Testing Testing Test g\n"
"Testing Testing Testing Test T")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")