using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Star Wars\s?\d?";
string input = @"La película Star Wars
La película Star Wars 4
La película Star Wars 5
La película StarWars ❌";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}