$re = '/Star Wars\s?\d?/';
$str = 'La película Star Wars
La película Star Wars 4
La película Star Wars 5
La película StarWars ❌';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);