$re = '/(?P<time>\d\d:\d\d:\d\d.\d{3})\s(?P<date>\d\d/\d\d/\d\d)\s.*?(?P<pr>Pt\s{3}\d+(?:\.\d+)?\s[a-z]+)/m';
$str = 'Something P LR 0.156462 sccm Pt 25.341343 psig something-else
12:37:25.790 08/05/20 Something P LR 0.156462 sccm Pt 25.341343 psig something-else
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);