import re
regex = re.compile(r"(?P<time>\d\d:\d\d:\d\d.\d{3})\s(?P<date>\d\d/\d\d/\d\d)\s.*?(?P<pr>Pt\s{3}\d+(?:\.\d+)?\s[a-z]+)", flags=re.MULTILINE)
test_str = ("Something P LR 0.156462 sccm Pt 25.341343 psig something-else\n\n"
"12:37:25.790 08/05/20 Something P LR 0.156462 sccm Pt 25.341343 psig something-else\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")