package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\p{Greek}+`)
var str = `
ἀ·κρασία, -ας, ἡ
Noun (Fem. 1st Decl.)
Not all forms below are necessarily attested. Highlighted words may or may not be a match to the GNT or LXX, if another word also inflects the same way.
1st Decl. Feminine Noun
Contracted Uncontracted
Sg Voc ακρασια ακρασι·α
Nom
Acc ακρασιαν[GNT] ακρασι·αν
Dat ακρασιᾳ ακρασι·ᾳ
Gen ακρασιας[GNT] ακρασι·ας
Pl Voc ακρασιαι ακρασι·αι
Nom
Acc ακρασιας[GNT] ακρασι·ας
Dat ακρασιαις[LXX] ακρασι·αις
Gen ακρασιων ακρασι·ων
Copyright 2007-2019 Thomas Moore, Email: acct3 at katabiblon.com, Support Forum Set Local Timezone
Sunday, 19-May-2019 15:55:07 EDT
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}