# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b\p{Greek}+"
test_str = ("\n"
"ἀ·κρασία, -ας, ἡ\n"
"Noun (Fem. 1st Decl.)\n\n"
"Not all forms below are necessarily attested. Highlighted words may or may not be a match to the GNT or LXX, if another word also inflects the same way.\n\n"
"1st Decl. Feminine Noun\n"
"Contracted Uncontracted\n"
"Sg Voc ακρασια ακρασι·α\n"
"Nom\n"
"Acc ακρασιαν[GNT] ακρασι·αν\n"
"Dat ακρασιᾳ ακρασι·ᾳ\n"
"Gen ακρασιας[GNT] ακρασι·ας\n"
"Pl Voc ακρασιαι ακρασι·αι\n"
"Nom\n"
"Acc ακρασιας[GNT] ακρασι·ας\n"
"Dat ακρασιαις[LXX] ακρασι·αις\n"
"Gen ακρασιων ακρασι·ων\n\n"
"Copyright 2007-2019 Thomas Moore, Email: acct3 at katabiblon.com, Support Forum Set Local Timezone \n"
"Sunday, 19-May-2019 15:55:07 EDT\n")
matches = re.finditer(regex, test_str, re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.