const regex = /\b\p{Greek}+/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\p{Greek}+', 'gu')
const str = `
ἀ·κρασία, -ας, ἡ
Noun (Fem. 1st Decl.)
Not all forms below are necessarily attested. Highlighted words may or may not be a match to the GNT or LXX, if another word also inflects the same way.
1st Decl. Feminine Noun
Contracted Uncontracted
Sg Voc ακρασια ακρασι·α
Nom
Acc ακρασιαν[GNT] ακρασι·αν
Dat ακρασιᾳ ακρασι·ᾳ
Gen ακρασιας[GNT] ακρασι·ας
Pl Voc ακρασιαι ακρασι·αι
Nom
Acc ακρασιας[GNT] ακρασι·ας
Dat ακρασιαις[LXX] ακρασι·αις
Gen ακρασιων ακρασι·ων
Copyright 2007-2019 Thomas Moore, Email: acct3 at katabiblon.com, Support Forum Set Local Timezone
Sunday, 19-May-2019 15:55:07 EDT
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}