import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"\b\p{Greek}+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
ἀ·κρασία, -ας, ἡ
Noun (Fem. 1st Decl.)
Not all forms below are necessarily attested. Highlighted words may or may not be a match to the GNT or LXX, if another word also inflects the same way.
1st Decl. Feminine Noun
Contracted Uncontracted
Sg Voc ακρασια ακρασι·α
Nom
Acc ακρασιαν[GNT] ακρασι·αν
Dat ακρασιᾳ ακρασι·ᾳ
Gen ακρασιας[GNT] ακρασι·ας
Pl Voc ακρασιαι ακρασι·αι
Nom
Acc ακρασιας[GNT] ακρασι·ας
Dat ακρασιαις[LXX] ακρασι·αις
Gen ακρασιων ακρασι·ων
Copyright 2007-2019 Thomas Moore, Email: acct3 at katabiblon.com, Support Forum Set Local Timezone
Sunday, 19-May-2019 15:55:07 EDT
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)