using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\b\w+\b.*(TS).*?(?=RMK)";
string input = @"KSTS 021853Z VRB04KT 10SM SCT026 17/12 A2989 RMK AO2 SLP115 T01670122
KSTS 021853Z VRB04KT 10SM SCT026 VCTS 17/12 A2989 RMK AO2 SLP115 T01670122
KSTS 021853Z VRB04KT 10SM SCT026 17/12 A2989 RMK AO2 SLP115 T01670122 TS01670122
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}