const regex = new RegExp('^\\b\\w+\\b.*(TS).*?(?=RMK)', 'gm')
const str = `KSTS 021853Z VRB04KT 10SM SCT026 17/12 A2989 RMK AO2 SLP115 T01670122
KSTS 021853Z VRB04KT 10SM SCT026 VCTS 17/12 A2989 RMK AO2 SLP115 T01670122
KSTS 021853Z VRB04KT 10SM SCT026 17/12 A2989 RMK AO2 SLP115 T01670122 TS01670122
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}