$re = '/^\b\w+\b.*(TS).*?(?=RMK)/m';
$str = 'KSTS 021853Z VRB04KT 10SM SCT026 17/12 A2989 RMK AO2 SLP115 T01670122
KSTS 021853Z VRB04KT 10SM SCT026 VCTS 17/12 A2989 RMK AO2 SLP115 T01670122
KSTS 021853Z VRB04KT 10SM SCT026 17/12 A2989 RMK AO2 SLP115 T01670122 TS01670122
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);