using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"BGP_CONNECT_FAILED: (?<BGP_connection>.*)";
string input = @"BGP_CONNECT_FAILED: bgp_connect_start: connect 2403:df40:0:16::3 (Internal AS 14630) (instance master): No route to host";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}