re = /BGP_CONNECT_FAILED: (?<BGP_connection>.*)/m
str = 'BGP_CONNECT_FAILED: bgp_connect_start: connect 2403:df40:0:16::3 (Internal AS 14630) (instance master): No route to host'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end