package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)BGP_CONNECT_FAILED: (?<BGP_connection>.*)`)
var str = `BGP_CONNECT_FAILED: bgp_connect_start: connect 2403:df40:0:16::3 (Internal AS 14630) (instance master): No route to host`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}