const regex = /BGP_CONNECT_FAILED: (?<BGP_connection>.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('BGP_CONNECT_FAILED: (?<BGP_connection>.*)', 'gm')
const str = `BGP_CONNECT_FAILED: bgp_connect_start: connect 2403:df40:0:16::3 (Internal AS 14630) (instance master): No route to host`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}