#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*?)=("?)([^"]+?)\2(?:,|$)"
Local $sString = "bDestruction=True,bEmissionAlarme=False,bActionReinit=False,sNatureData="Sur évènement provenant d'ALIS ou SGP - Lignes BJ, IJ ou GMO",sCodeMsgExpliControle="MSG-G00033_P_ALIM_ME""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")