$re = '/(.*?)=("?)([^"]+?)\2(?:,|$)/';
$str = 'bDestruction=True,bEmissionAlarme=False,bActionReinit=False,sNatureData="Sur évènement provenant d\'ALIS ou SGP - Lignes BJ, IJ ou GMO",sCodeMsgExpliControle="MSG-G00033_P_ALIM_ME"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);