import Foundation
let pattern = #"(.*?)=("?)([^"]+?)\2(?:,|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"bDestruction=True,bEmissionAlarme=False,bActionReinit=False,sNatureData="Sur évènement provenant d'ALIS ou SGP - Lignes BJ, IJ ou GMO",sCodeMsgExpliControle="MSG-G00033_P_ALIM_ME""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)