using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)=(""?)([^""]+?)\2(?:,|$)";
string input = @"bDestruction=True,bEmissionAlarme=False,bActionReinit=False,sNatureData=""Sur évènement provenant d'ALIS ou SGP - Lignes BJ, IJ ou GMO"",sCodeMsgExpliControle=""MSG-G00033_P_ALIM_ME""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}